# Friday, 25 February 2011
« Learning From Others | Main | How Data Annotation Validators work on e... »

Visual Studio 2010 or Visual Web Developer Express 2010 or Visual Phone Developer Express 2010 that matches the language version of Silverlight Tools 4 must be installed before installation of Silverlight Tools can continue.

I was running into the above error when I tried to install Silverlight 4 Tools for Visual Studio 2010 whether I did it from the downloaded install or via the Web Platform Installer.

Downloaded Silverlight4_Tools.exe error message:

image 

WPI:

image

If you open the first log file you will find the error at the bottom:

Installation Blockers:
    1) Visual Studio 2010 or Visual Web Developer Express 2010 or Visual Phone Developer Express 2010 that matches the language version of Silverlight Tools 4 must be installed before installation of Silverlight Tools can continue.  Silverlight Tools is available in other languages at <A HREF="http://go.microsoft.com/fwlink/?LinkId=177432">http://go.microsoft.com/fwlink/?LinkId=177432</A>.

When I looked online for this error I was only seeing references to the Beta and Release Candidates of Visual Studio 2010.

After a little thought, I decided to open up the readme file for the SP1 Beta of Visual Studio 2010 that I installed a while back and there was the answer:

2.1.4. Error when you try to install Silverlight 4 Tools for Visual Studio 2010 on Visual Studio 2010 SP1 Beta

An error message may appear when you try to install Silverlight 4 Tools for Visual Studio 2010 on Visual Studio 2010 SP1 Beta. 

To resolve this issue:

Because Silverlight 4 Tools for Visual Studio 2010 (http://www.microsoft.com/downloads/en/details.aspx?FamilyID=b3deb194-ca86-4fb6-a716-b67c2604a139&displayLang=en) is included in Visual Studio 2010 SP1 Beta, you do not have to install Silverlight 4 tools separately.  Also, you do not have to uninstall Silverlight 4 Tools for Visual Studio 2010 before you install Visual Studio SP1 Beta.

There you have it.  If you installed VS 2010 SP1 Beta then you already have the Silverlight 4 Tools.  How’s that for a descriptive error message. :-)

Happy Coding!

Thursday, 08 September 2011 11:16:54 (US Mountain Standard Time, UTC-07:00)
Thanks for this post. It was driving me crazy!
Thursday, 08 September 2011 13:14:20 (US Mountain Standard Time, UTC-07:00)
Your welcome! Glad to help another fellow out. :-)
Thursday, 10 November 2011 12:33:03 (US Mountain Standard Time, UTC-07:00)
I have the same pb
Thursday, 10 November 2011 12:33:54 (US Mountain Standard Time, UTC-07:00)
I have same pb
I need help
Thursday, 10 November 2011 13:43:20 (US Mountain Standard Time, UTC-07:00)
The post states that if you have this error going on and you've already installed Visual Studio 2010 SP1 then you already have the tools? Is this not the case for you?
Monday, 05 March 2012 10:25:54 (US Mountain Standard Time, UTC-07:00)
m getting the same error for silverlight 5 installation..how do i correct it?
aakshi
OpenID
Please login with either your OpenID above, or your details below.
Name
E-mail
(will show your gravatar icon)
Home page

Comment (Some html is allowed: b, blockquote@cite, em, i, strike) where the @ means "attribute." For example, you can use <a href="" title=""> or <blockquote cite="Scott">.  

[Captcha]Enter the code shown (prevents robots):

Live Comment Preview